Xcode - Resolvendo o problema "[MT] PluginLoading: Required plug-in compatibility"

Por paulo, Qui 10 Dezembro 2015, na categoria Xcode

error, plugin, problema, uuid, xcode

Olá,

Aqui vai uma dica para quem atualizou o Xcode e começou a receber o seguinte erro ao executar alguma coisa via linha de comando no terminal:

[MT] PluginLoading: Required plug-in compatibility UUID XYZ for plug-in at path XYZ

Basta seguir os passos:

1 - Abra o Terminal

2 - Execute:

XCODEUUID=`defaults read /Applications/Xcode.app/Contents/Info DVTPlugInCompatibilityUUID`

3 - Execute:

for f in ~/Library/Application\ Support/Developer/Shared/Xcode/Plug-ins/*; do defaults write "$f/Contents/Info" DVTPlugInCompatibilityUUIDs -array-add $XCODEUUID; done

Obrigado e até o próximo post pessoal.

Outros conteúdos relacionados

Qui 18 Fevereiro 2016
Xcode - Corrigindo o erro "This certificate has an invalid issuer"
Sáb 13 Dezembro 2014
Mobile - Nova versão do iPacote feito com Swift da Apple
Sáb 13 Dezembro 2014
Cloud/Nuvem - Como instalar e configurar a biblioteca Parse do Facebook no Xcode